Compatibility Check

Because a lot of training material that runs within a Virtual Learning Environment (VLE), needs to meet certain criteria, we have developed this simple test page to check your browser and whether you have Flash installed.

We are continually striving to make all our courses cross-compatibile with all major systems. Please see the browser compatibility check list and Flash player detection below. Most of our courses require Flash Player (version 10 or above) to run correctly.

Flash Player Version Detection:


Oh dear your browser is not compatible

DOM Manipulation:

Your browser does not have DOM Manipulation support

Please use the links above to download the latest browser for your operating system.


NOTE: In many managed IT environments, individual users will not have sufficient permissions to do the download,
and in this case the download may appear to work almost instantaneously, but will not actually have taken place.
If this happens, then a user with sufficient administration rights (e.g. IT support) will have to do the download.
If you are still having trouble please contact us on 01943 605976 to discuss your options.

Note on Browsers

To the best of our knowledge our courses are fully compatible with the following systems

Windows Logo to highlight compatiblityWindows based system using Internet Explorer Firefox Chrome Safari Opera

Apple Logo to highlight compatiblityMac OSX (OS 10), using Safari or Firefox

Linux Logo to highlight compatiblityLinux / Unix based systems using Firefox.

If you do encounter any errors on this page, please contact us on 01943 605976, and we will help you try and resolve them.